Пример 2. Интервальная таблица частот в MS Excel

При построении интервальной таблицы частот в MS Excel возникают определенные трудности. Для автоматического подсчета абсолютных частот теперь нельзя использовать функцию СЧЕТЕСЛИ() так, как мы делали это в обычной, не интервальной таблице: эта функция в качестве возможных условий подсчета допускает лишь

=, >, <, <=, >=,

а нам нужно проверять попадание каждого значения в интервал (т.е. использовать двойное неравенство).

Однако выход и здесь существует. Нужно найти сначала накопленные абсолютные частоты. Для их отыскания достаточно проверять условие <= (меньше или равно):

СЧЕТЕСЛИ(Диапазон; "<="&ПравыйКонецИнтервала)

Обратите внимание на знак & - он служит здесь для того, чтобы "приклеить" к знаку неравенства содержимое ячейки, где находится правый конец каждого очередного интервала.

Ниже показано, как построить этим способом интервальную таблицу частот для выборки цен на различные модели ноутбуков (данные взяты из сети Интренет-магазинов).

Интервальная таблица частот строилась следующим образом:

  1. Ранжируем, т.е. упорядочим исходный ряд и определим диапазон изменения цен - от 585 до 4289.
  2. Для упрощения расширим границы диапазона до 500 и 4500 и разобъем его на 8 равных интервалов по 500$.
  3. Введем границы всех интервалов в столбцы C и D.
  4. В ячейке E3 найдем накопленную абсолютную частоту по формуле=СЧЁТЕСЛИ($A$1:$A$296;"<="&D3).
  5. Эту формулу размножим на весь столбец E.
  6. В ячейке F3 найдем абсолютную частоту первого значения по формуле =E3.
  7. В ячейке F4 найдем абсолютную частоту второго значения по формуле =E4-E3.
  8. Эту формулу размножим на весь столбец F.
  9. Далее действуем как для обыкновенной таблицы частот.